目录
首页 笔记 详情

WordPress中如何引入默认jQuery并在特别jQuery版本中使用$()写法


WordPress 中有默认的jQuery库,所以我们是做插件以及主题开发不需要额外引入及对其版本没有要求的话,直接使用WordPress的jQuery库即可。下面最基本的引入方法:

<?php    wp_enqueue_script("jquery");

微妙的是这个独有的通用jQuery版本里,使用($)是无法工作的。所以我们很多开发者没有找到这个兼容的写法,下面我们举例说明:

/* 到处可见的写法 */
$("#some-element").wp-jpost();

/* WordPress下的安全写法 */
jQuery("#some-element").wp-jpost();

WP 的 jQuery 和原版唯一的不同, 就是在最后一行加了 jQuery.noConflict();这个noConflict() 就是为了与其它的library 兼容性, 如:Prototype, MooTools, 或 YUI.

如果我们需要使用到处可见的那种$()的写法的话,必须要使用下面的写法:

jQuery(document).ready(function( $ ) {
	
	// 这里就能愉快的使用$()开头啦~~~
	
});

写笔记

咨询

您的电子邮箱地址不会被公开。 必填项已用*标注